#SCCM 2012SP1 – Component Server not uninstalling

tl;dr: restart SMS_SITE_COMPONENT_MANAGER service through Configuration Manager Service Manager

 

After uninstalling a SUP from a Site Server, the Component Server Role was not disappearing from the roles-listing of the old site system.

After searching a while I found this blogpost for the 2007 SCCM environment. It also works in an 2012SP1 environment:

1. In your SCCM Console open Monitoring and choose site status.

2. look for a component server an right click it. Select Start –> Configuration Manager Service Manager

3. In the service Manager, expand a working server and navigate to SMS_SITE_COMPONENT_MANAGER

4. Select SMS_SITE_COMPONENT_MANAGER and right click it. Select query. After a short time you will get the recent service status.

5. now you can stop the service: right click it and select stop service

6. query the service again

7. start the service: rights click and start service

8. Take a look in your site administration: the Component Server role should be gone

Hope that helps Smiley

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s